Update from Cloudflare: We are seeing services recover, but customers may continue to observe higher-than-normal error rates as we continue remediation efforts.
Posted Nov 18, 2025 - 12:31 UTC
Update
We are continuing to monitor for any further issues.
Posted Nov 18, 2025 - 12:25 UTC
Update
Unfortunately, Cloudflare is still experiencing an issue which impacts multiple customers: Widespread 500 errors,
Posted Nov 18, 2025 - 12:23 UTC
Update
We are continuing to monitor for any further issues.
Posted Nov 18, 2025 - 12:17 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 18, 2025 - 12:15 UTC
Update
Cloudflare is aware of, and investigating an issue which impacts multiple customers: Widespread 500 errors, Cloudflare Dashboard and API also failing.
Posted Nov 18, 2025 - 12:13 UTC
Investigating
We are currently investigating this issue.
Posted Nov 18, 2025 - 11:57 UTC
This incident affected: Venice App, Venice API, and Venice API Docs.