Resolving as this is a duplicate status update. Please see the other incident for updates.
Posted Feb 19, 2026 - 16:38 UTC
Investigating
We are tracking an issue with a major internet infrastructure provider that may be the causing Venice as well as other sites not to respond in a timely fashion.
Posted Feb 19, 2026 - 16:32 UTC
This incident affected: Venice App and Venice API.