System Maintenance

Incident Report for Venice

Resolved

Maintenance is complete.
Posted Mar 08, 2026 - 12:32 UTC

Monitoring

Maintenance is complete and we are verifying functionality.
Posted Mar 08, 2026 - 11:46 UTC

Identified

We're performing an infrastructure upgrade to support Venice's rapid growth. The app and API will be temporarily unavailable.
Posted Mar 08, 2026 - 11:25 UTC
This incident affected: Venice App and Venice API.